Symptom
You will receive the error HTTP Code: 302(Redirect) during the below scenarios:-
-
When you try to access the WSID created.
- When you try to test the service from SDK.
- When you try to check the connection in the communictaion arrangement.
Environment
SAP CLOUD APPLICATION STUDIO
SAP BUSINESS ByDESIGN
SAP HYBRIS CLOUD FOR CUSTOMER
Reproducing the Issue
-
Login to the frontend UI.
- Navigate to the Application and User Management work Center.
- Select the Communication Arrangement sub view.
- Find the Communication Arrangement which you have created.
- Edit and go to Technical Data tab.
- Click on Edit Advanced Settings button.
- Select the service and click on Check Connection button.
- Ping fails with the error.
Cause
This issue occurs if you have not maintained the Path field in the Advanced Settings of the respective communication arrangement.
Resolution
Follow the same path mentioned in the steps to reproduce and find the field Path in the Advanced Settings. Once you maintain the path here and activate the communication arrangement the issue will be resolved.
Keywords
HTTP Code: 302(Redirect) Path missing External webservice not working , KBA , 302 redirect , external webservice error during testing , redirect 302 error , pdi , AP-RC-BDS-WS , ByDesign Studio Web Services , Problem