Symptom
The Click to Call functionality is available for Account, Individual Customers, Leads, Contacts and Tickets.
While you are assigning work centers to a Business Role, you could find Live Activity work center under Service , but you are unable to find it under Sales.
You expectation is that since Click to Call is introduced for Sales as well a different Live Activity work center should be available under Sales.
Reproducing the Issue
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Go to Administrator work center.
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Go to General Settings view.
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Click on Business Roles hyperlink under Users section.
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Select 123(where 123 is a Business Role ID ).
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Click on View All.
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Navigate to Work center and View assignments.
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Here under Sales work center you cannot find Live Activity.
Cause
Outbound Call Handling (Click-to-Call) is a Service feature. So you want to activate outbound call on Sales, the Live Activity work center ( Service ) needs to be assigned to the user.
You will need to have Service scenario + Sales scenario integrated.
Resolution
This is the expected system behavior.
Keywords
Click to call , service, Account , KBA , leads , contacts , tickets , LOD-CRM-SRP , Service Request Processing , Problem