SAP Knowledge Base Article - Public

2642893 - Language Determination for Service Request Form Template

Symptom

You created a new form template variant for Service Requests by selecting a specific country and language during the creation. However, after publishing the form template, you notice that the system selects a different form template than the one you created.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service Work Center.
  2. Select the Tickets view.
  3. Open any ticket.
  4. Click on the Actions menu.
  5. Select Generate Summary.
  6. In the dropdown, choose "Service Request" and click Preview.

Observe that the system selects a different form template instead of the newly created one form template.

Cause

Form templates like Service request are configured with specific languages but without country assignment. For these non-customer-facing documents, the logon language determines the template that is previewed. Specifying a country for such templates may restrict their determination, leading to selection mismatches.​

Resolution

This is the expected system behavior. Do not assign a country to form templates such as Service Requests. By default, these templates are configured with a language variant only and no country assignment. Assigning a country to these templates may cause selection or determination issues in document processing.

Keywords

service request, form template, ticket, summary, preview, language, variant , KBA , AP-RC-OUT , Output Management , Problem

Product

SAP Cloud for Customer add-ins all versions