Symptom
The value for employee responsible is being sent from Hybris Marketing (YMT) to C4C within a lead replication request, however the value is not updating in the C4C Lead.
Environment
SAP Hybris Cloud for Customer
SAP Hybris Marketing
Reproducing the Issue
Send a LeanLeadReplicationInitiatedByExternalIn message from YMT to C4C which contains an employee responsible present in the C4C system.
Cause
Business partners can only be replicated from C4C to YMT and not in the opposite direction. If an employee responsible or another related business partner exists in C4C and is sent as part of a payload from YMT, and this does not update the value stored in C4C, there is an issue with the ID mapping maintained for this communication system. Hybris marketing uses a longer ID number for business partners than most other SAP systems which C4C integrates with and as a result it makes use of the External Business Partner mapping type.
Resolution
-
Go to the Administrator work centre.
- Go to the ID Mapping for Integration view.
- Click on the Edit ID Mapping for Integration link.
- Enter the correct value for System Instance ID.
- Select Mapping Of External Business Partner.
- Enter the YMT ID for the Emplopyee in the External ID field.
- Click Go to confirm that no mapping exists.
- Updating the ID mapping to maintain a value.
- Resend the problematic LeanLeadReplicationInitiatedByExternalIn message.
Keywords
LeanLeadReplicationInitiatedByExternalIn, Employee Responsible, Hybris Marketing, YMKT, ID Mapping , KBA , LOD-CRM-INT-YMT , Integration of C4C with Marketing , How To