Symptom
- You are not able to add an Eligible user that was rehired to a worksheet.
- The system says that an Eligible user who was rehired is not eligible when adding to a worksheet.
Environment
- Compensation
- Variable Pay
- Employee Central
Reproducing the Issue
Go to:
- Compensation Home
- Select a Template
- Manage Worksheets
- Add Employee
- System says Employee is not Eligible even though they are
Cause
Sometimes due to the termination and rehire of an employee the system may not read the eligibility rules created correctly when calculating if an employee is eligible or not. This can be down to the paremeters that are configured for the eligibility rule.
Resolution
For terminated and rehired users, it is always recommended to use jobInfo (Job Information) for rule definition. For example:
Base Object - Job Information
Rule Condition - Job Information.Company equals to X,Y,Z Etc
To update the rule go to:
- Configure Business Rules
- Search the eligibility rule name
- Click "Take Action" and then "Make Correction".
Once you have updated the rule you have to re-run it. Go to:
- Compensation Home
- Select Template
- Plan Setup
- Plan Details - Eligibility
- Click Apply Rule
Keywords
Rehire, Rehired, Terminated, Eligibility, Not Eligible, Worksheet, Add Employees, Compensation, Cant Add, Eligibility Rule, EC Integrated , KBA , LOD-SF-CMP , Compensation Management , LOD-SF-VRP , Variable Pay Programs , Problem