Symptom
- We are unable to hire user via the add new employee wizard
- We are unable to rehire user’s
- We are unable to edit time off fields in job info
- We are unable to terminate users via MSS
Environment
- Employee Central – Time Sheet
- Employee Central – Job Information
- Employee Central – Hire/Rehire
Reproducing the Issue
1. Try to hire a user via Add new employee wizard and submit the hire
2. Try to save a time off info field change in job info
3. Try to click save when trying to terminate a user
Cause
The engineering team are currently investigating the issue and what the root cause is
Resolution
The current workaround is to do the following
1. Go to Manage Data
2. Search for time management configuration object
3. Click Take Action
4. Change the Schedule Immediate Recalculation field to Never and Save
Afterwards only the event for the recalculation is created but no job is scheduled immediately. Therefore, job info changes can be successfully saved. If the job is disabled the daily recalculation run should still fail, but the recalculation events will be processed after the problem is resolved.
Product Support, please see internal memo
Keywords
Unable to process new hires, Application Error, Unable to terminate employee, unable to save records for new hires or rehires, Edit Time Off Fields in Job Info, JobSchedulerImpl.scheduleAndRunJob: Failed to schedule and run a job request, SchedulerServiceJobDisabledException: Job has been disabled, ScheduleTLMImpl.executeTLM(ScheduleTLMImpl.java:70), PLT-71116 , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-JOB , Job Information , Problem