SAP Knowledge Base Article - Public

2644283 - How To Remove Employee (Service Technician) From C4C Stock

Symptom

The employee / service technician assinged to a stock in C4C / ERP leaves the company and needs to be removed from the stock.

Environment

SAP Hybris Cloud For Customer integration with SAP ERP.

Cause

Its not possible to unassign or remove the  employee / service technician from the UI. The deletion must be performed in ERP and replicated to C4C.

Resolution

If an employee (service technician) leaves the company then you need to set (check box) the deletion flag in the table view COD_V_PLANT_SRV. This will make the report RCOD_STOCK_EXTRACT to set the DEL_FLAG in the IDOC COD_STOCK_REPLICATE01 and the corresponding employee record will be deleted from C4C.

Keywords

KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions