Symptom
You are trying to edit employee data in the Employees work center view of the People work center, but find that it's not possible as most fields are greyed out.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the People work center.
- Select the Employees view.
- Select and open any employee.
- Click Edit.
You can see that most of the fields on the header are grayed out and cannot be edited.
Cause
This is the expected system behavior.
Resolution
The Employee maintenance in the People work center is designed in a way that you can only maintain your own profile data, but for other employees, the related fields in the header are read-only (a setting that cannot be changed via Key User Tools).
If you want to maintain data in your own profile, you may perform the below steps:
- Log into the system.
- Click on your user icon at the upper-right corner of the screen.
- In your Profile scree, click Edit.
- In the header section, you will be able to maintain the Address and Contact information for your Profile.
- Once done, click Save.
The Employee data of all employees can only be maintained in the Employees view in the Administrator work center.
- Go to the Administrator work center.
- Select the General Settings view.
- Click the Employees hyperlink under the Users section.
- Select the relevant employee.
- Click Edit.
Note: here you can also find the Additional Name Fields hyperlink, where you can maintain middle name(s), nicknames, etc.
Keywords
Employee, People work center, Edit, middle name, nickname, added name , KBA , LOD-CRM-EMP , Employee , Problem