Symptom
You try to create a new survey, however, when you click on the New button you receive the error 'Survey ID is missing. Please contact your power user'.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Surveys work center.
- Go to the Surveys view.
- Click on the New button.
- The error 'Survey ID is missing. Please contact your power user.' appears.
Cause
In your system, there are two BC (Business Configuration) projects maintained.
The main BC projects does not have the survey scope. Technically, there are two adaptation workspaces.
The main adaptation workspace does not have the question 'Do you want to maintain surveys in the system?' switched on.
Resolution
-
Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Click on the Edit Project Scope button.
- Click on the Next button until reach tab 3: Review Questions.
- Go to Sales -> Account and Activity Management -> Activity Management.
- Under Survey, check the question 'Do you want to maintain surveys in the system?'.
- Save.
Keywords
New survey; Survey ID; Create; ID; Error; New; Power User. , KBA , LOD-LE-SUR-DEF , Survey definition = design time , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions