SAP Knowledge Base Article - Public

2645306 - Error: “ISS-046: E-mail example@example.com is already taken. Please enter a different e-mail address” While Accessing the Views in E-mail Integration Work Center

Symptom

Your requirement is to understand if E-mail Integration work center views are accessible. Upon accessing the User Settings view or Groupware Settings view, you receive the below error:

ISS-046: E-mail example@example.com is already taken. Please enter a different e-mail address

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to E-mail Integration work center
  2. Go to the respective views User Settings or Groupware Settings
  3. Able to see the mentioned error

Cause

The error is displayed due to one of the below reasons:

  1. Error message is due to blank E-Mail ID maintained for the logged in Business User.
  2. There are two Business Users in the system, who have the same E-Mail Address maintained.
  3. There is a mismatch between the User ID in Business Users view and Groupware Settings view. For example, under Business Users View the user ID maintained for user "Test" is XY, but in Groupware Settings the user ID for same user is XYZ.

Resolution

E-mail ID should not be blank for any user. While loading the iCRM UIs, each Business User is identified by a unique E-Mail address. Therefore, the user trying to access should have unique E-Mail address.

The default E-mail ID which is example@example.com can only be used or maintained for one Business User whose E-Mail ID is blank. But for all other users it must be uniquely maintained.

To successfully access E-mail Integration work center, you may follow one of the below options:

  1. Maintain unique E-Mail ID for the Business User trying to access E-mail Integration work center.
  2. If 2 Business Users have the same E-mail address maintained, change the E-Mail Address of one of the Users.
  3. If there is mismatch between the User ID you need to delete the user from groupware settings and create a new one with same user ID as you have under Business Users work center view.

Keywords

ISS-046, E-Mail Already Taken, E-mail Integration, Email Integration, E-mail ID, User Settings, Groupware Settings  , KBA , email integration , e-mail integration , e-mail id , groupware settings , email id , user settings , iss-046 , LOD-CRM-INT-OEM , Provisioning issues for OEM integration (eg iCRM) , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions