Symptom
Selecting a given Country of Birth (for which the region of birth is enabled), the Region Of Birth instead of listing picklist values displays "NO DATA".
However, the Business Configuration UI for Biographical Information is correct per Legacy Data Model
Environment
Employee Central - Biographical Information
Employee Central - Home Address
Reproducing the Issue
- Access a User from a Country for which Region Of Birth enabled (ex-Brazil)
- Go to Biographical Information
- Country Of Birth
- Region Of Birth shows "NO DATA"
Cause
Configuration Problem: The picklist for tha country (ex. ) has been removed from the picklist.
To check this please proceed as follows:
A- Check the Address
- Go to any user
- Go to Address portlet
- Select the affected Country
- There is no picklist for the "State" no value displayed either
B- Check BCUI
- Go to Manage Business Configuration, in Coutry Specific area
- Check the State picklist (for our example Bra)
C - Check the picklist
- Download the picklist from the system
- Filter for State
- The State value for the country with issue is missing in this example "STATE_BRA" would be missing
Resolution
As of Date, Hard-coded Picklist for Region of Birth exist for countries Italy, France, Venezuela, Brazil and Chile
Therefore the problem described here will concern one or all of the above countries or any other countries as curently supported
To correct the problem:
Add the missing State value to the picklist and import back into the system.
Set the picklist for State in BCUI
The region of birth will then display as expected.
And the address info will also dispay the state as appropriate
See Also
2247688 - Cannot load field Region of Birth in Biographical info
Keywords
Region of birth, country of birth, state, no data , KBA , LOD-SF-EC-PER-BIO , Biographical Info - Config, Rules, RBP, UI , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem