Symptom
This article describes the root cause for keyword tag not appearing in Candidate Search.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting.
- Go to Candidates Tab.
- When you go to Candidate Search, you will not find the keyword tag or have the ability to search keywords in the resume or coverletter.
- Expected Behavior:
Cause
In your Candidate Profile template, either the resume field or coverLetter field is marked as sensitive="true". This is what it looks like in Manage Templates:
Resolution
- Edit the Candidate Profile and set both the resume field and coverLetter field to sensitive="false."
- Sample code setup:
<field-definition id="resume" type="richText" required="true" custom="false" anonymize="true" sensitive="true">
<field-definition id="coverLetter" type="richText" required="false" custom="false" anonymize="true" sensitive="true">
See Also
2556844 - New Tag for identifying sensitive personal Data (SPD) - RCM
Keywords
Sensitive Tag; Candidate Profile; Keyword Search, keyword and item search, candidate search , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem