Symptom
You opened the preview of the standard data source Ticket Survey Answers (technical ID CODTKTSURVEYANS) and the characteristic Survey Answer Date does not show any data.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Business Analytics work center.
- Go to the Design Data Sources view.
- Search for data source Ticket Survey Answer (technical ID CODTKTSURVEYANS).
- Select the data source and click Preview.
- Click Go.
- Go to the tab Available Fields and add characteristic Survey Answer Date to the view.
- You will notice that it displays no data (#).
Cause
The characteristic Survey Answer Date, shows the answer for the date/date range type of question. In your system, there is no question of type date/date range, hence no answer is available. Furthermore this field is blank and showing # in the standard data source Ticket Survey Answer.
Resolution
If you want to see the date time at which the survey was last responded to, this information can be derived from the characteristic Survey Last Change Date Time.
In case you only want to see the completed surveys, please add the characteristic Survey Life Cycle Status to the data source view.
Keywords
Survey Answer Date; Ticket Survey Answers; CODTKTSURVEYANS; Standard Data Source; no data; Survey , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-LE-SUR-DEF , Survey definition = design time , How To