SAP Knowledge Base Article - Public

2645632 - Warning: 'Initial contact instance detected. Please enter an ID or delete' In A Sales Quote

Symptom

You observe the warning message 'Initial contact instance detected. Please enter an ID or delete' while opening a Sales Quote.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to Sales work center.
  2. Go to Sales Quotes view.
  3. Open the Sales Quote XYZ (Where XYZ indicates the Sales Quote ID).
  4. Warning message appears: 'Initial contact instance detected. Please enter an ID or delete'.

Cause

This warning message appears if there is an initial contact in the involved parties of the Sales Quote. The system issues the warning message to give a hint to the user to fill the initial (blank contact line without contact content) line.

The system allows the user to Add a contact without information as in some use-cases this may be added at a later point.

Resolution

In cases where you get such a warning message, please follow the steps below and verify if there are any initial contacts in the Sales Quote.

  1. Go to the Sales work center.
  2. Go to the Sales Quotes view.
  3. Open the Sales Quote  XYZ (Where XYZ indicates the Sales Quote ID).
  4. Go to the Involved Parties facet.
  5. Select the Account party and check if there are any initial (empty) lines in the Contacts subfacet.
  6. If no such initial lines are found, do the same steps for other parties and verify there are no initial contacts.
  7. If any initial (blank) lines are found, either delete them by clicking on the delete icon or enter the relevant information.
  8. Click on Save.

Keywords

initial contact, initial, sales quote, warning, instance , KBA , sales quote , id , initial contact , initial instance , LOD-LE-CQP , Customer Quote Processing , LOD-LE-CQP-CO , Lean Sales Orders , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions