Symptom
You click to reply to an e-mail in Service Ticket Interactions and the e-mail reply dialog box pops up, but the buttons Send, Save As Draft and Cancel are outside the current view area and hence inaccessible.
Environment
SAP Hybris Cloud For Customer Fiori UI
Reproducing the Issue
-
Go to Service Work Center.
- Go to Tickets.
- Select any ticket where you have an e-mail interaction.
- Go to Interactions facet / tab.
- Click on the Reply button for the respective e-mail interaction.
- The e-mail reply dialog box will pop up.
Cause
The e-mail reply dialog box is a responsive box, but it still has a minimum height set of 600px and a minimun width of 870px. This minimum size is set to ensure that users gets enough writing space in the rich text area which is one of the main usability concerns.
Taking the above into consideration this can then be caused by a number of reasons, being the most common:
-
Low screen resolution: If your monitor uses a very low resolution (e.g. 1366 X 768), you will consequently have less space to display objects on the screen.
- Too many toolbars: If you have too many toolbars being displayed on your browser you may leave not enough space for the application to display its content.
Resolution
To resolve this behaviour you'll have to first understand the possible cause as seen above.
Solutions to this include:
-
Increase your monitor resolution.
- Reduce the number of displayed toolbars and/or concatenate your toolbars to use a single bar on your browser.
- You can drag the reply dialog box up so it will display the missing buttons from the bottom.
Keywords
E-mail Reply, Send, Save As Draft, Cancel, Ticket Interactions , KBA , LOD-CRM-SRP-INT , Ticket Interactions , Problem