Symptom
Some or all forms do not appear under Performance History Block in the Employee Profile
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Performance Management
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Navigate to the Employee Profile
- Check the Performance History Block where the Forms are expected to appear
Cause
There are multiple causes for this, as described below, in different areas of the system
Configure People Profile Settings:
- The set date range does not include Talent data within the range
- An Incorrect Process is selected
- The Include In-Progress Forms option is not selected, if the expectation is to see in History Block forms that are in progress
Processes and Forms
Templates are not included in the process selected under Configure People Profile > General Settings
Note: The process can be configured under 'Processes and Forms' tool that can be simply accessed via 'Search Tool' under Admin Center.
The user viewing the History Block and not seeing Forms is not a part of the Form Route Map. The user must be part of the route map of the form
Person-Based Performance History Block in People Profile
The Missing forms could be related to the another employment for the same user, for this scenario, we have the enhancement to show forms from multiple employments.
The Performance History block in People Profile can now show employees' performance review data from multiple employments. It can also show inactive users' performance history.
If Admin Center > Company System and Logo Settings > Enable Person-Based Performance History Block is selected, when users review the Performance History block of employees' one employment, they're informed that the block shows information from all employments. If there's no performance history, they're informed that no data is found for any employments. The exact number of employments that users view depends on their granted permissions.
Further info on this feature is related in the Implementation Guide.
Resolution
- Make sure the set date range is correct according to the Talent data
- Validate the correct process is selected
- Ensure the In-Progress Forms option is selected where applicable
- Make sure performance templates are included in the process selected
See Also
Keywords
PM, EP, sf, success factors, PMGM, Talent, talent data, history block,blocks, forms, data, ratings, information, employee profile, processes and forms, configure people profile, settings, date range, missing data, missed, missing forms, data not showing, inactive user, inactive , KBA , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , Problem