Symptom
Recurring Invoices were created successfully earlier but has stopped now. And even though now you create new Recurring Invoices runs the Invoices are still not created.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Supplier Invoicing work center.
- Go to Recurring Invoices view.
- Select an active document.
- Under details go to Invoice History tab.
Where you don't see Invoices as per the recurrence pattern you maintained; There is no Invoices at all; Few Invoices were created later Invoices are not getting created.
Cause
Cause 1:
Since no job exists the invoices are not getting created.
If you have selected the job run and click on cancel job, since the job is canceled it will not be visible under All Scheduled jobs anymore.
or
While rescheduling the job, if you choose schedule immediately or use any other option other than 'Recurrence' option then also job gets completed and will not visible anymore.
Cause 2:
If job already exists as mentioned above then run date and time is not yet reached or occurred.
Resolution
For Cause 1:
Job run will get created again by system automatically the next day if this issue happens in Production tenant only.
Once the job is available ensure that you never cancel it or ensure to reschedule the job only using recurrence option to avoid this issue in the future.
Please raise incident if you face this issue in test, development or demo tenant and we will create a job in backend manually.
For Cause 2:
Steps to check whether the job exists or not:
- Go to Application and User Management work center.
- Go to Background Jobs view.
- Filter for All Scheduled Jobs.
- Search for job run with description Recurring Invoice for All Buyers.
Steps to check Next start date/time of the run:
- Go to application user management.
- Go to background jobs view.
- Select Recurring invoicing for all buyers.
- You see that it has date and time of next job run.
- The time zone is same as what you have set under personalize settings.
Steps to reschedule the Job run:
- Go to Application User Management work center.
- Go to Background Jobs view.
- Select Recurring Invoices for All Buyers click on Reschedule button.
- Choose checkbox Recurrence.
- Enter date as next day and time as 00:30 in UTC (convert time 00:30 in UTC to your time zone same as your personalize settings and enter the time).
- Or enter current date and any time for example 5 mins more than your current time so that you will only have to wait for only 5 mins for the job run to happen.
See Also
2910570 - Error message:Creation date of next invoice is before current date
2135564 - Supplier Invoice not Created From A Recurring Invoice Maintained
Keywords
Recurring Invoice, Invoice Job Not Appearing, Background Job Disappeared, Recurring invoices are highlighted in pink, Creation Date of Next Invoice , KBA , recurring job not available , AP-SIP-SIV , Supplier Invoice , How To