Symptom
Ticket Routing Rules do not automatically stop to assign tickets to the deleted territory.
Environment
SAP Cloud for Customer
Reproducing the Issue
- You create a Ticket Routing Rule with conditions to assign tickets to territory XYZ (XYZ represents the name of the territory).
- Territory XYZ has been deleted.
- You find that for new tickets, the Ticket Routing Rule is still working and assigns tickets to the deleted territory XYZ.
Cause
The Ticket Routing Rules don't do validation of the final output of the rule engine to check if the output territory is valid or not. Business rule framework can only provide the output value from the row which matches the ticket attributes.
Resolution
To resolve the issue, you need to manually change the Routing Rule after you deleted the related territory.
Keywords
Ticket Routing Rule, Territory, Ticket , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions