Symptom
Updating Business Communication fields for a service agent is not possible as the fields are greyed out.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Partners Workcenter.Select the subview "Service Agents."
- Change the view to "Show All."
- Search for the desired Service Agent.
- Click "Edit" button.
- In the General tab, the Business Communication fields are greyed out.
Cause
The Business Communication fields are greyed out because the Main Address for the Service Agent is not maintained.
Resolution
To enable updating of Business Communication, please maintain the Main Address for the Service Agent.
- Navigate to the Business Partner Data Workcenter.
- Select the Subview "Service Agent."
- Choose the desired Service Agent.
- Click "Edit" button.
- Navigate to the "Addresses" tab.
- Select "Add Row" and enter the required address details to maintain a Main Address.
Once this is completed, the Business Communication fields will be editable.
Keywords
Business Partners, Service Agent, Business Communication , KBA , AP-BP-BP , BusinessByDesign: Business Partner , How To
Product
SAP Business ByDesign all versions