SAP Knowledge Base Article - Public

2650668 - Unable to Update the Business Communication Field in Service Agent records

Symptom

Updating Business Communication fields for a service agent is not possible as the fields are greyed out.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Business Partners Workcenter.Select the subview "Service Agents."
  2. Change the view to "Show All."
  3. Search for the desired Service Agent.
  4. Click "Edit" button.
  5. In the General tab, the Business Communication fields are greyed out.

Cause

The Business Communication fields are greyed out because the Main Address for the Service Agent is not maintained.

Resolution

To enable updating of Business Communication, please maintain the Main Address for the Service Agent.

  1. Navigate to the Business Partner Data Workcenter.
  2. Select the Subview "Service Agent."
  3. Choose the desired Service Agent.
  4. Click "Edit" button.
  5. Navigate to the "Addresses" tab.
  6. Select "Add Row" and enter the required address details to maintain a Main Address.

Once this is completed, the Business Communication fields will be editable.

Keywords

Business Partners, Service Agent, Business Communication , KBA , AP-BP-BP , BusinessByDesign: Business Partner , How To

Product

SAP Business ByDesign all versions