Symptom
You are using the action Associate Account and Contact in a Lead. You are not selecting an existing account from the duplicate check pane to the right and saving it; the system icreates a Prospect instead of an Account in this case.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center.
- Open the Leads view.
- Open the Lead ABC (where ABC stands as ID of a Lead eligible for associating an Account and Contact).
- Click in the Actions button.
- Select Associate Account and Contact.
- Fill in the needed fields in the Associate Account and Contact pop-up.
- The system will suggest accounts in the right pane (duplicate check) based on the fields filled in the step 6.
- Click in the Save and Open button (not selecting any of the accounts suggested in the right pane).
- In the Lead ABC header, click in the account hyperlink.
The created record will be an Prospect (Prospect checkbox flagged) and you expected an Account instead (Prospect checkbox unflagged).
Cause
You are using the action Associate Account and Contact in a Lead. The system expects that existing accounts will be selected by doing this. With the information provided and still no account selected, the system infers that you are still dealing with a prospect in this case.
Resolution
This is the system current standard behavior. If you intend to create a new account since the first moment, you should use the option Convert to Account and Contact in the Lead Actions menu instead of Associate Account and Contact .
Keywords
Lead ; Account ; Prospect ; Associate Account and Contact ; Create ; , KBA , LOD-CRM-LM , Lead Management , How To