Symptom
You are trying to assign marketing attributes to an account in C4C via "MarketingAttributeAssignmentReplicationRequestIn" but you get an error "Attriute XYZ Is Missing" (XYZ represents the Attribute ID)
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
1) Go to Webservice Message Monitoring View
2) Select the incoming message failed with interface "MarketingAttributeAssignmentReplicationRequestIn"
3) Navigate to Error Log and check the error "Attribute XYZ is missing"
4) Now go to Administrator view
5) Go to Sales and Campaign Settings
6) Maintain Marketing Attributes
7) Search with XYZ , you can find the attribute is actually available in C4C
Cause
You are sending Attributes without reference to Attribute Set
Resolution
1) Ensure that Attribute is added to Attribute Set as prerequisite
2) While sending assignments to C4C , ensure that you will send AttributeSetID apart from AttributeID(s) from CRM system
Keywords
MarketingAttributeAssignmentReplicationRequestIn, Cloud for Customer, CRM, Attribute , KBA , LOD-CRM-INT-CRM , Integration of C4C with CRM , Problem