SAP Knowledge Base Article - Preview

2651684 - Node.js engine matching 4.x is not provided by the current version of the XS OnPremise runtime.

Symptom

After upgrade to HANA 2 SP3 the deployment of a Node.js application fails with this error:

#com.sap.lm.sl.alm.5336.MAIN_LOG#
######com.sap.lm.sl.alm.prod.installer.process.steps.StepsUtil########pool-7-thread-3###
[PollStateStep] Node.js
Node.js buildpack version 3.4.3
Available Node.js runtimes: node8.9,node6.12
Error: Node.js engine matching 4.x is not provided by the current version of the XS OnPremise runtime.


Read more...

Environment

SAP HANA 2 SP3 with XS Advanced engine.

Product

SAP HANA, enterprise extended edition all versions

Keywords

Node.js 4.x , KBA , BC-XS-RT , XS Advanced Runtime / XS Controller , BC-XS-JS , Javascript runtime , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.