Symptom
You receive error message in the Web Service Message Monitoring: "Missing channel e-mail address in recipient fields (TO or CC)".
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Administrator work center.
- Go to the General settings view.
- Under System Administration, click hyperlink Web Service Message Monitoring.
- Select relevant error message id.
Error: "Missing channel e-mail address in recipient fields (TO or CC)".
Cause
- This error could indicate one of three things:
- The incoming e-mail didn't have any direct recipients, it is all the e-mail recipients were in BCC.
- The relevant setting under "Administrator -> Service and Social -> E-mail Addresses" for said e-mail channel is either incorrect or incomplete.
- The same e-mail address has extra hidden spaces or characters, which are not understood by the system.
- In said cases, the system would reject the incoming e-mail with the error: "Missing channel e-mail address in recipient fields (TO or CC)".
Resolution
- If it is the first case (as mentioned above), then
- ensure the support of the e-mail channels in CC and or BCC is configured correctly
- see "Configuring E-Mail Channels" and
- KBA 2963754 - How To Enable Support Channel In BCC
- If it is the second case, you need to maintain the channel and then the message can be resent.
- For the 3rd case, you will need to:
- copy the e-mail address in notepad
- paste it back in the UI
- verify the e-mail, reactivate, and retest with a new inbound e-mail
Keywords
Web service message monitoring, e-mail, TO, CC, channel, missing, recipient , KBA , incoming error message , webservice message monitoring , csg_q , email , missing , e-mail , channel , servicerequestingin , recipient , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-INT , Ticket Interactions , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions