SAP Knowledge Base Article - Public

2652158 - Error: Missing channel e-mail address in recipient fields (TO or CC)

Symptom

You receive error message in the Web Service Message Monitoring: "Missing channel e-mail address in recipient fields (TO or CC)".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the General settings view.
  3. Under System Administration, click hyperlink Web Service Message Monitoring.
  4. Select relevant error message id.

Error: "Missing channel e-mail address in recipient fields (TO or CC)".

Cause

  • This error could indicate one of three things:
    1. The incoming e-mail didn't have any direct recipients, it is all the e-mail recipients were in BCC.
    2. The relevant setting under "Administrator -> Service and Social -> E-mail Addresses" for said e-mail channel is either incorrect or incomplete.
    3. The same e-mail address has extra hidden spaces or characters, which are not understood by the system.
    4. The email provider sent the email with wrong or missing separators, not allowing the system to be able to identify the sender (e.g the recipients were XXX@sap.comYYY@sap.com instead of XXX@sap.com; YYY@sap.com). 
  • In said cases, the system would reject the incoming e-mail with the error: "Missing channel e-mail address in recipient fields (TO or CC)".
  • You are using the technical email (eg. B2B Support Scenario: cod.b2b.servicerequest@myXXXXXX.mail.crm.ondemand.com; B2C Support Scenario: cod.servicerequest@myXXXXXX.mail.crm.ondemand.com; Employee Support Scenario: cod.employeesupport@myXXXXXX.mail.crm.ondemand.com) - in this case, as this cannot be used as Email Channel, this will not create Tickets.

Resolution

  • If it is the first case (as mentioned above), then
  • If it is the second case, you need to maintain the channel and then the message can be resent. 
  • For the 3rd case, you will need to:
    1. copy the e-mail address in notepad
    2. paste it back in the UI
    3. verify the e-mail, reactivate, and retest with a new inbound e-mail
  • For the 4rd point, check your outbound mime or SMTP Logs from your email provider, validate the missing/wrong separators and follow up with the team responsible for your company email server configuration, so that they can make sure the separators are correctly passed. 

Keywords

Web service message monitoring, e-mail, TO, CC, channel, missing, recipient

, KBA , incoming error message , webservice message monitoring , csg_q , email , missing , e-mail , channel , recipient , servicerequestingin , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-INT , Ticket Interactions , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions