Symptom
Getting below error when creating a new benefit contact
Environment
- SuccessFactors Employee Central
- Global Benefits
Reproducing the Issue
Navigate to admin center--->Benefits admin overview---->create new benefit contact--->save--->above error appears
Cause
Contact ID is a mandatory field and its blank since visibilty of the field is read only.
Resolution
Change the visibility of Contact ID field to editable
Navigate to admin center--->Configure object definition---->Search benefit contact---->Click details section of the field externalCode --->Set the visibility to editable--->Save
Keywords
Contact id cannot be empty benefit contact benefit admin overview , KBA , LOD-SF-EC-GBF , Global Benefits , Problem
Product
SAP SuccessFactors Employee Central all versions