Symptom
Sending E-mail Is Not Possible due the Error Message "Sending E-mail Is Not Possible, No Sender Available".
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Customer work center.
- Go to the Account work view.
- Open Account ABC (ABC defined an account ID).
- Go to the Activities facet.
- Click on new e-mail button.
- Write an e-mail.
- Click on Send.
The error message "Sending e-mail is not possible, no sender available" and "Save Failed" will be displayed.
Cause
May exist two causes for these error messages:
-
The business user which is marked as the employee responsible is not maintained as employee in the system.
- The domain is not part of the list of supported domains maintained in the fine tuning - E-mail and Fax Settings.
Resolution
This is the expected system behavior.
To solve the first cause, the user should maintain the employee responsible as an employee.
To solve the second cause, the user should maintain the domain configured on business configuration; on fine tune; at E-mail and Fax Settings:
-
Go to the Business Configuration work center.
- Go to the Implementation Projects work view.
- Click on Open Activity List.
- Search and click on the activity E-mail and Fax Settings.
- Click on E-mail and Fax Settings.
- Add the domain under Allowed Sender E-Mail Domains. (Example: the email used is ABC@DEF.COM, so the domain to be maintained here should be DEF.COM)
- Click on Save and Close.
See Also
SAP Help Portal - Configure Employee
SAP Help Portal - Configuring E-mail Channels
Keywords
Activities, e-mail, sender , KBA , LOD-CRM-ACT , Activities , LOD-CRM-SC-EML , Email , How To