SAP Knowledge Base Article - Public

2653080 - Admin is missing server location field when trying to upload content

Symptom

When trying to import content through import tool, the admin is missing the server location field.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Login on LMS as an Admin;
  2. Navigate to Content > Tools > Import Content;
  3. Select the desired option and click next;
  4. Browse and select the file then click next;
  5. Notice the missing options.

Cause

The admin role is missing the "Access Deploy Content To Server" and "Search Content Deployment Location" permissions.

Resolution

Add the Access Deploy Content To Server and the Search Content Deployment Location permissions to the admin role:

  1. Open the admin role in edit mode (System Administration > Security > Role Management) and navigate to Permissions;
  2. Click on add one or more from list option;
  3. Expand the Content option AND the Search group;
  4. Select the box to add Access Deploy Content To Server and Search Content Deployment Location;
  5. Click on the add button;
  6. Click on Apply Changes.

Keywords

Content, LMS, Deployment Location, server, sap, import, permission , KBA , LOD-SF-LMS-WOR , Roles & Workflows , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions