Symptom
When trying to import content through import tool, the admin is missing the server location field.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
-
Login on LMS as an Admin;
- Navigate to Content > Tools > Import Content;
- Select the desired option and click next;
- Browse and select the file then click next;
- Notice the missing options.
Cause
The admin role is missing the "Access Deploy Content To Server" and "Search Content Deployment Location" permissions.
Resolution
Add the Access Deploy Content To Server and the Search Content Deployment Location permissions to the admin role:
-
Open the admin role in edit mode (System Administration > Security > Role Management) and navigate to Permissions;
- Click on add one or more from list option;
- Expand the Content option AND the Search group;
- Select the box to add Access Deploy Content To Server and Search Content Deployment Location;
- Click on the add button;
- Click on Apply Changes.
Keywords
Content, LMS, Deployment Location, server, sap, import, permission , KBA , LOD-SF-LMS-WOR , Roles & Workflows , LOD-SF-LMS , Learning Management System , Problem
Product
SAP SuccessFactors Learning all versions