Symptom
Cannot complete a new hire, rehire or pending hire due to the error 'Nationality and Second Nationality cannot be the same'.
Environment
SAP SuccessFactors Employee Central - New Hire/Rehire Wizards.
Reproducing the Issue
1. Create a new hire via the Add New Employee wizard.
2. Complete the personal information section and click continue.
3. The following error appears:
Note: During a rehire or hiring from pending recruits, this error will appear when moving from the identity section to the personal information section of the hiring process.
Cause
As of the b1805 release, a validation has been added to ensure that the personal information fields "Nationality" and "Second Nationality" have unique values. If the values for these fields are not unique, then the error will occur.
Resolution
If the error is occuring during the Add New Employee wizard, please maintain a unique value for the personal information fields "Nationality" and "Second Nationality".
If the error is occuring during the Manage Pending Hires wizard, please update the candidate profiles to have different values for "Nationality" and "Second Nationality" -> (Admin Center > Recruiting > Candidates tab > Search Candidate > Update profile then hire).
Keywords
1805, Nationality Error, Second Nationality, Nationality and Second Nationality cannot be the same, Hire, Rehire. , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , Problem