SAP Knowledge Base Article - Public

2654405 - How Many Conditions can be Added in the Workflow

Symptom

Is there lmit for number of group condition to be added in the Workflow.

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Workflow view.
  3. Click on the New button to create new workflow.
  4. In the New Workflow screen select Business Object as XYZ1(where XYZ1 is type of business object) and maintain other mandatory fields.
  5. Click next and go to Conditions section.

Is there limit on number of group condition we can maintain?

Cause

It depends again on two factors.

  1. The number of workflow rules for a given business object, which would have to be evaluated.
  2. The number of conditions per workflow rule.

If there is one rule and it has N-numbers of condition, evaluation should still be very quick. But if there are multiple rules for a given business object then evaluation for each along with the number of conditions per rule would have a very significant impact on performance.

Resolution

This is expected system behavior.

Keywords

Administrator, New Workflow , Group Condition , KBA , number of conditions limit , multiple rule for business object , single rule , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions