Symptom
Is there lmit for number of group condition to be added in the Workflow.
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Workflow view.
- Click on the New button to create new workflow.
- In the New Workflow screen select Business Object as XYZ1(where XYZ1 is type of business object) and maintain other mandatory fields.
- Click next and go to Conditions section.
Is there limit on number of group condition we can maintain?
Cause
It depends again on two factors.
- The number of workflow rules for a given business object, which would have to be evaluated.
- The number of conditions per workflow rule.
If there is one rule and it has N-numbers of condition, evaluation should still be very quick. But if there are multiple rules for a given business object then evaluation for each along with the number of conditions per rule would have a very significant impact on performance.
Resolution
This is expected system behavior.
Keywords
Administrator, New Workflow , Group Condition , KBA , number of conditions limit , multiple rule for business object , single rule , LOD-CRM-WKF , Workflow , How To