Symptom
Created appointment has a PDF Attachment.The workflow is triggered and email is received, however received email does is without an attachment.
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Workflow Rules view.
- Click on the New button and select Business Object as Appointment from drop down option with Rule type "E-mail" and Timing as On Every Save/Scheduled.
- Click on Next and go to the Define Conditions section.
- Fileds "Always Send E-Mail" , "Create E-Mail Activity" and "Add Attachment " are checked.
- An activity is created which holds an attachment "XXXX" (where XXXX is the name of an activity).
- Activity is saved and workflow is triggered succssfully to send an email. Received email does not show attachment XXXX.
Cause
This features of sending the Files present as an attachment of Appointment using workflow does not exist.
Resolution
This is expected system behaviour.
When a Workflow is created for an Activity Business Object, Attachments in the created activity will not be will not be replicated and received via email.
Workflow supports two ways to send Attachment in the email.
1. Standard template which are exposed by Application owners can be used to send as attachment via workflow by following below steps:
- Select the option "PDF Form Template" in "Define Action section", while defining workflow rule. Select the option "PDF Form Template". This selects
standard template exposed by application which can be send as an attachment.
2. In case user wants to send their own custom template, then
- Define workflow rule and select the checkbox "Add Attachment", in "Define Action section" step.
- Custom logic to attach any template, must be created by the user.
Keywords
PDF, activity, attachment, workflow rule, receive email, template, Not received, file, custom, logic, action , KBA , pdf, activity, attachment, workflow rule , LOD-CRM-WKF , Workflow , LOD-CRM-ACT , Activities , Problem