SAP Knowledge Base Article - Public

2654985 - Access Rights for Business Users View Not Working as Expected

Symptom

In the Administrator work center, users have access to Business Users view while they are not assigned to it or they are able to edit Business Users even though they have it restricted as Read Only.

Environment

SAP Hybris Cloud for Customer - HTML5 UI.

Reproducing the Issue

  1. Go to Administrator work center.
  2. Open Business Users.
  3. Users have access to this view, even though they are not assigned with it or they are able to edit it, even though their access is restricted to Read Only.

Cause

This occurs when the user is assigned with the General Settings view, which also release access to the Business Users view.

Also, if the user has access to the Business Users view restricted as Read Only, but there is no restriction in the General Settings view, they will be able to edit the business users.

Resolution

Either remove the access to the General Settings view or users will also have access to Business Users view if it is still assigned.

As for the Business Users access restrictions, they will be overruled by the General Settings access restriction if this view is also assigned.

Keywords

business users; access restriction; general settings; view; administrator; , KBA , access restriction , edit business users , administrator , SRD-CC-IAM , Identity & Access Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions