Symptom
Target Group contains duplicate members.
Environment
SAP Cloud for Customer
Reproducing the Issue
This is the same for both static and dynamic Target Groups, the example below is for a dynamic target group.
-
Go to the Sales Campaign work centre.
- Go to the Target Groups work view.
- Create a new target group with member determination enabled.
- Go to the Member Determination facet.
- Add a new
- Maintain determination.
- Configure the Target Group.
- Verify on the Member facet that the same contact is determined more than once and it is related to different accounts.
Because of this, when you add this target group to a Sales Campaign, the contact will receive the campaign for each time that it is defined on the target group.
Cause
This behavior is caused, for example, by dynamic target groups where the contact is based on marketing attribute conditions. All the contacts with their associated accounts will be added which have the same marketing attributes maintained.
The system verifies the unique relationship with contacts - not the email address associated to it.
Resolution
This is the current system behavior. The condition that the user had maintained is returning correct result in dynamic target group.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
See Also
SAP Admin Guide - Configuring Dynamic Target Groups
Keywords
Target Groups, Campaign, Dynamic, Contacts, Account. , KBA , LOD-CRM-MKT-CAM , Campaigns , How To