Symptom
You have set a rule for a KUT field e.g. Reason for Closure to be mandatory if the Task Status is set to Completed. Setting the Task via Actions -> Set to Completed does not trigger the rule and the change is saved.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to Activities work center.
- Select Tasks view.
- Open any Task in status Open.
- Click on Actions and select Set to Completed.
Cause
This is the standard system behavior.
Resolution
The rule is not triggered as the task itself is not edited via Edit button but changed via Actions button. This is also confirmed as the rule will work once you re-open the Task that is completed and click on Edit and try to save without maintaining the KUT field with the rule.
Keywords
rule editor; rule; rules; task; tasks; activities; actions; action; set to complete; completed; edit; , KBA , rule editor , rule , rules , task , tasks , activities , actions , action , set to complete , completed , edit , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Product Enhancement