Symptom
When editing any of the followng fields, IBAN field is cleared: Bank Country, Account Number, Routing Number, Business Identifier Code (BIC)
Environment
Employee Central - Payment Information
Reproducing the Issue
1. Navigate to the Profile of a user with Payment Information saved
2. Click to edit
3. Make a change to Bank Country, Account Number, Routing Number or Business Identifier Code (BIC) field
4. IBAN field is cleared
Cause
This is caused by the proposeIBAN_PaymentInfoDetails rule. This rule is no longer supported and the function it uses has now been depreciated.
Resolution
To resolve, you will need to unassign the proposeIBAN_PaymentInfoDetails rule from the following objects:
1. Payment Information Detail: fields Bank Country, Account Number, Routing Number, and Business Identifier Code (BIC)
2. Payment Information Detail FRA: field checkDigit
3. Payment Information Detail ESP: field checkDigit
See Also
This is also detailed in the Implementing and Configuring Payment Information in Employee Central Handbook.
Keywords
IBAN, BIC, Bank Country, Account Number, Routing Number, Business Identifier Code, (BIC), Cleared, Deleted, proposeIBAN_PaymentInfoDetails, Payment Information, Edit , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC , Employee Central , Problem