SAP Knowledge Base Article - Public

2655485 - Receiver system could not be determined

Symptom

In C4C Web Service Message monitoring, there are erroneous messages with text :

CX_MBF_EXCEPTION:An exception occurred.Receiver system could not be determined.Receiver system could not be determined.

CX_AP_DATA_REPL_MAPPING_ABORT:An exception occurred.Multiple business instances detected for logical system XYZ.An exception was raised.

Multiple business instances detected for logical system XYZ.

where 'XYZ' represents the Business System ID.

Environment

SAP C4C

Reproducing the Issue

1. Go to Customer Work centre.

2.Go to Accounts

3.Change some data in any account details.

4.Go to Administrator

5.Wo to Web Service Message Monitoring

6.For the corresponding change, there are error messages as above.

Cause

The error root cause is : More than one system which is connected to the C4C system, has same BusinessSystemID.

Resolution

1.Go to Administrator Work Centre.

2.Navigate to Communication Systems

3.Click on each of the "Communication System ID"

4. Ensure that each of the Communication system IDs have unique "Business System ID".

5. If more than one Communication system IDs have same "Business System ID", then change them to unique values.

BusinessSystemID.JPGn

Keywords

Multiple business instances detected for logical system XYZ.   , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-CRM , Integration of C4C with CRM , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions