SAP Knowledge Base Article - Public

2655611 - Code List Restrictions Is Not Working For Field Ticket Type

Symptom

Using Code List Restrictions you have set the Default value for field Ticket Type to be empty, but this field still defaults to 'Employee Support Ticket'.

Reproducing the Issue

  1. Go to Service work center.
  2. Go to Tickets view.
  3. Click on New.
  4. The Type field is filled with 'Employee Support Ticket' as per Code List Restrictions.
  5. Navigate to Administrator work center.
  6. Go to General settings view and open Code List Restrictions.
  7. Here the rule set is for Business Object = Ticket , Control Field = Any  and Code to Restrict = Ticket Type. 
  8. Go to Default Values tab and set the Code Default value to Empty , which means for any control field the default value of Ticket Type should be empty.

This is not working as the Ticket Type field is filled with 'Employee Support Ticket'.

Cause

As per current system behavior we cannot have Ticket Type field as Blank.

For any instance of the Ticket, we need to know the Ticket type, because there are lot of follow on features like Status Management,ATP , Release to ERP and all these functionalities are dependent on the Ticket type.

Also, this has to be decided when the instance is created and cannot be changed later, so we need a value for Ticket Type field.

Resolution

We suggest you to maintain one of the Ticket Type values as Default value.

Keywords

Ticket, default,control field , KBA , employee support , ticket type , LOD-CRM-SRP , Service Request Processing , LOD-CRM-PM-SRV , C4C Product Management - Service , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions