Symptom
The 'Pricing' facet is missing in the sales quote or order object.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Sales Orders view.
- Open the sales order 123 (123 represents the sales order ID).
- The facet Pricing is missing and cannot be added via Edit Master Layout.
Cause
The document type of your sales quote or sales order has maintenance mode "External" or "Internal & External". The Pricing facet is only available for internal quotes and orders.
Note: in Adaptation mode you will see fields/sections/tabs/facets etc. that are related to the basic UI frame of a view. This means, a field/ section/ facet/ etc. might show up during adaptation mode and be set to visible - but won't be actually visible in the UI itself. This is the case if the element has another condition set by the system. Such a condition will be the requirement for it's visibility. Only if that condition is met will it actually show up in the UI. Those can be document type, scoping, stage of progress, etc.
For example, the Employee field is only available in the 'All Accounts' query - not under the 'My Accounts' query (the 'my' query already sets the employee = logged in user, the field is not relevant for that query and can therefore not be set to visible under that query).
Another example are the Territory fields which depend on your Territory scoping (Multiple vs Single Territory scoping). Further, certain elements are available on a SALES contract, which are not visible in a SERVICE contract, etc.
Resolution
This is the system expected behavior.
To maintain the document as internal, follow the below steps:
- Go to the Business Configuration work center.
- Go to Overview facet.
- Open the fine-tune activity Sales Orders.
- Maintain Document Types.
- Maintain the required document type as "Internal".
Keywords
Pricing, Facet, Missing, External Pricing, Internal, Sales Order, Sales Quote , KBA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-LE-CQP , Customer Quote Processing , How To