SAP Knowledge Base Article - Public

2656168 - Duplicate entries in Table, detailed reporting or tile/dashboard with Collaborative step - Performance Management

Symptom

When generating Performance Management report in Table, detailed reporting or tile/dashboard, it gives duplicate entries for every user.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Generate a Table, detailed reporting or tile/dashboard
  2. Select the Columns. 
  3. You are seeing duplicates in the report.

Cause

This is the expected system behavior if you have used Collaborative steps in your Route Map. It is not a duplicate entry however, it is populating entries for each role involved in that particular step of the route map.

Resolution

There report may return multiple entries when the form's current route map step type is a Collaborative step and your report includes "Current route step name" or any route map related columns.

If you wish to show only one row, please remove any columns related to the route map such as Current Route Step Name or Current Owner.

Another workaround is to just add the column "Current Route Step Name (Locale Specific)" in your report or dashboards. This would allow users to see the column in their respective locale should it differ from the default language (Only if the labels are provided in the users locale). However as soon as you add other route map step related columns, the report may return two entries again for each of the role in the collaborative step.

See Also

2628547 - Form Status Tile Returns Duplicate Entries in Drilldown

2434426 - Ad Hoc Reports and Dashboards Route Map Step Localization

Keywords

Adhoc Report, Table, detailed reporting or tile/dashboard, Collaborative, Current route step, duplicate rows form report , KBA , LOD-SF-PM-REP , Reporting & Analytics, Data Imports & Exports , Problem

Product

SAP SuccessFactors HCM suite all versions