SAP Knowledge Base Article - Public

2656729 - Exception when attempting to unassign item using User Needs Mgmt Tool

Symptom

Receive stack error when scheduling job for User Needs Mgmt Tool to remove item from multiple users learning plan:

com.plateau.common.jobscheduling.api.JobBatchProcessingException: com.plateausystems.elms.util.helper.ElmsDeleteException: Cannot delete the components from the SF CDP due to WS exception
...
Caused by: com.plateau.sfintegration.impl.webservices.out.cdp.service.CDPServiceException: com.plateausystems.elms.util.helper.ElmsFinderException: could not get ComponentVO
...
Caused by: com.plateausystems.elms.util.helper.ElmsFinderException: could not get ComponentVO
...
Caused by: com.plateausystems.elms.util.helper.ElmsNoRecordFoundException: getComponentVO(pk): Could not find record <Customer's Item key here>

Environment

SAP SuccessFactors Learning Management System (LMS)

Cause

Issue is caused by invalid or courrupt data when item was created generally the revision date and by a connector.

Resolution

Resolved by one of the following:

  • Revise the item & propagate to users and retry User Needs Mgmt tool to remove.
  • Manually remove item from user via LMS Admin view.
  • Engage Professional Services to correct bad data.

Keywords

SF Learning LMS management need items executed schedule scheduled java errors , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions