Symptom
Receive stack error when scheduling job for User Needs Mgmt Tool to remove item from multiple users learning plan:
com.plateau.common.jobscheduling.api.JobBatchProcessingException: com.plateausystems.elms.util.helper.ElmsDeleteException: Cannot delete the components from the SF CDP due to WS exception
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Caused by: com.plateau.sfintegration.impl.webservices.out.cdp.service.CDPServiceException: com.plateausystems.elms.util.helper.ElmsFinderException: could not get ComponentVO
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Caused by: com.plateausystems.elms.util.helper.ElmsFinderException: could not get ComponentVO
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Caused by: com.plateausystems.elms.util.helper.ElmsNoRecordFoundException: getComponentVO(pk): Could not find record <Customer's Item key here>
Environment
SAP SuccessFactors Learning
Cause
Issue is caused by invalid or corrupt data when item was created generally and issue with the revision date and by a connector.
Resolution
Resolved by one of the following:
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Revise the item & propagate to users and retry User Needs Mgmt tool to remove.
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Manually remove item from user via LMS Admin view.
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Engage Professional Services to correct bad data.
Keywords
SF Learning, LMS management, need items, execute,d schedule, scheduled, java errors , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem
SAP Knowledge Base Article - Public