Symptom
Onboarding Test Instance contains employee data that is associated with real employees and candidates in the Production Instance.
Environment
SuccessFactors Onboarding
Reproducing the Issue
1. When viewing the Onboarding Test instance, you notice employee information that should only exist in the Production Instance.
2. This information can be associated with employee data and email notifications as well as other areas where employee data is utilised.
3. Examples are, but not limited to;
a. Mail Queue
b. Audit Trail
Cause
This information was copied from the Production Instance to the Test Instance during an account refresh request.
The Following must be considered when a customer submits an instance refresh request:
- When the customer submits a refresh request to SF Support they have the option to either copy this employee data or to omit it from the instance refresh, employee data in a production instance contains sensitive and personal information.
- Below is the question associated with this data which exists in the refresh request form that the customer provides to SF Support.
- Do you need employee data, notifications, etc. to be copied from Source to Destination?
- The customer will answer Yes or No to this question.
- No - No employee data will be copied.
- Yes - Employee data will be copied from the source account to the destination account.
Resolution
If the answer to the employee data question is Yes, but the customer decides that they do not want this data in the destination account after the refresh has been processed, Support will need to do the following;
- Clarify what data they want removed from the destination account and if they would like the data to be backed up.
- Obtain email approval from the customer which contains their explicit permission to remove the data from the affected account and whether or not they need it backed up.
- Raise a COSR Jira to have the data removed and attach the email with the customers approval to the COSR.
- When the Operations Engineers have confirmed that the data has been deleted, report back to the customer and have them confirm this from their end.
Keywords
Account Refresh, Onboarding, Employee Data, Mail Queue, Audit Trail, Personal Information , KBA , LOD-SF-OBD-EML , Emails and Notifications , Problem