SAP Knowledge Base Article - Public

2657857 - Activities Are Deleted when the Contact Is Anonymized by Personal Data Removal

Symptom

Activities are deleted when the contact is anonymized by personal data removal.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Data Protection and Privacy work center.
  2. Go to the Personal Data Removal work view.
  3. Search and select the contact 123 (where 123 designates the contact ID).
  4. Click on Remove Data.
  5. Click on Delete after the Remove Contact Person Data screen is raised. 
  6. On the question "Do you really want to delete this contact?" click Yes.
  7. Data is removed.

Verify that the activities linked to contact 123 were deleted.

Cause

The activities (Appointment, Phone Call, Task, Email and Visit) linked to a contact should be deleted in accordance with the General Data Privacy Regulation.

Resolution

This is the expected system behavior.

See Also

SAP Help Portal Admin Guide - Data Protection and Privacy

Keywords

Activities, Data Protection and Privacy, Deleted, Contacts. , KBA , LOD-CRM-ACT , Activities , LOD-CRM-SEC , Security Topics , How To

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1805 ; SAP Cloud for Customer add-ins 1808