Symptom
You are expecting that the functionality Personal Data Removal also anonymize Surveys from the system.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Select the ticket XYZ (XYZ represents the ID of the Ticket).
- Hover your mouse to the Cogwheel.
- Click and select the option Depersonalize.
- Open the Ticket you Depersonalized.
- Check that the whole Ticket is anonymized
- Go to the Survey facet.
- Open the Survey added to this Ticket.
- Result: The Survey is still showing the data.
Cause
Surveys are not consider a confidential document.
Resolution
This is current system behavior.
If this feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Surveys ; Personal Data Removal ; Anonymize , KBA , LOD-LE-SUR-EXE , Survey execution = runtime , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions