SAP Knowledge Base Article - Public

2658348 - Access Restrictions For Accounts Are Not Working

Symptom

The user USER01(where USER01 is a Business User) has maintained Access Restrictions for Accounts but still he is able to see Accounts which should not be visible to him as per the restrictions maintained.

Reproducing the Issue

  1. Log in with User USER01.
  2. Go to Customers work center.
  3. Go to Accounts view.

Multiple Accounts which should not be visible to this user are displayed, though Read and Write restrictions are maintained correctly.

Cause

Any Account which is not assigned an Owner will be visbile to everyone, irrespective of the Access Restrictions maintained. Since there is no Owner attached to the Account, this lies as an Orphan Account & hence is accessible to all.

Resolution

To Resolve this issue kindly maintain an Owner for all the Accounts.

Keywords

Account, Owner, View All Accounts, Access, Accounts View, Customer Workcenter , KBA , read access , write access , business role , customer , user , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions