SAP Knowledge Base Article - Public

2658393 - Account and Contact Person Are Not Copied into the Activity Task from Source Document

Symptom

A Workflow Rule has been configured to trigger the creation of an Activity Task for a certain sales document (e.g. Opportunity, Lead, Sales Order). When the Activity Task is created through the Workflow Rule the Account and Contact Person of the source document are not copied automatically into the Activity Task.

Environment

SAP Cloud for Customer

Reproducing the Issue

Steps to create a Workflow Rule which will create the Activity Task:

  1. Go to the Administration work center.
  2. Go to the Workflow Rule view.
  3. Click on the New button.
  4. Define a Business Object and Timing, in this example we will use the Sales Order to Business Object and On Every Save timing, and click on Next button.
  5. Define the Conditions that will trigger the workflow action, we will use Account equal to Account ABC, and click on Next button (ABC represents the Account ID).
  6. Select the Rule Type Activity Task and select the checkbox "Always Create Activity Task", fill in the rest of the mandatory fields and click on Next button.
  7. Click on the button Activate and after that on the Finish button.

 Steps to Reproduce the Issue:

  1. Go to the Sales work center.
  2. Go to the Sales Order view.
  3. Click on New button.
  4. Fill in the Account field with the Account ABC, and fill in the rest of the mandatory fields.
  5. Click on Save and Open button.
  6. Go to the Activities facet.
  7. Open the Task created through the Workflow Rule.
  8. The Account and Contact Person are not copied from the sales order into the Activity Task.

Cause

This is the expected system behavior.

The Account and Contact Person on the activity created through Workflow Rule are filled as per the recipient. That is, if the recipient is an account, then that account and it's main contact will be filled. If the recipient is a contact, then that contact and it's main account will be filled. If the account doesn't have a contact then no contact will be filled and vice-versa. And if the recipient is an employee (which doesn't have any account/contact) associated, no account/contact will be filled.

This was the case with Email and Messaging Activity but for Activity Tasks only in case the Workflow Rule was configured under Account/Contact/Individual on Customer work center, the Account and Contact Person was getting filled in the Task Activity.

Resolution

The feature to determine Account and Contact Person from the source object for the Activities created through Workflow Rules needs to be activated.

To enable this functionality, follow below steps:

  1. Go to the Administration work center.
  2. Go to the Workflow Rule view.
  3. Click 'More' -> select 'Workflow Settings'.
  4. Under Activity Creation, you need to select the checkbox “Determine Account and Contact from source object for the Activities created through Workflow Rule”. 

Keywords

Account, Contact Person, Workflow Rule, Activity Task , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions