SAP Knowledge Base Article - Public

2658454 - Workflow Rule to Trigger Action "Refresh from Activity Plan" Not Working

Symptom

You have created a Workflow Rule to trigger the action "Refresh from Activity Plan" in order to assign Survey automatically to a Lead, but it is not working when you define the condition based on Creation Date time for the Activity Routing Rule.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center .
  2. Go to the Leads view.
  3. Click on New.
  4. Fill all requested information.
  5. Select Save and Open.
  6. Newly created Lead will be opened.
  7. Go to the Survey Tab.
  8. You will be able to see that surveys are not automatically assigned although the workflow was triggered.

Cause

This is the expected system behavior.

 Determination to populate System administration data like Creation Date time of object instance executes after execution of workflow rule. As a result, while execution of workflow rule, Creation Date of object instance will be empty and condition defined on Creation Date will never suffice.

Resolution

The system does not support the condition Creation Date time on Activity Routing Rule if the workflow rule is supposed to execute on create of object instance.

Keywords

Creation Data, Condition, Workflow Rule, Activity Routing Rule, Activity Plan , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions