SAP Knowledge Base Article - Public

2658477 - "Dates configured for form” Cannot be Selected in the Launch Forms Tool

Symptom

In the Launch Forms Review Period tab, the “Dates configured for form” cannot be selected for any cloned Performance Form Template.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Clone any PM Form Template by going to Admin Center -> Manage Templates -> [[Name of the PM Template]]. Then, click “Save As”. Put a name to your cloned PM Template. Then, click “Save”;
  2. Go to Admin Center -> Launch Forms. Select the newly cloned PM Template;
  3. Click “Next” until you reach the tab called “Review Period”. As you can see, the radio button for “Dates configured for form” is not greyed out and cannot be selected:

15.JPG

Cause

This is expected behavior for all cloned Templates. The “Dates configured for form” cannot be selected as the default date settings have not been updated.

Go to Form Template Settings and update the following settings:

  • Default Start Date
  • Default End Date
  • Default Due Date

16.JPG

Resolution

  1. In the Form Template Settings -> [[Name of the cloned PM Template]], enter any temporary Fixed Dates for Default Start Date, Default End Date, and Default Due Date;
  2. Scroll down and click “Update Form Template” to "refresh" the cloned PM Template;
  3. Scroll up once again. This time, you may need to remove the dates you configured in step 1;
  4. Scroll down once again. Then, click “Update Form Template”;
  5. Finally, you may go back to Admin Center -> Launch Forms.

The “Dates configured for form” can be selected for that PM Template.

Keywords

Dates not configurable, Launch form, PM GM template , KBA , LOD-SF-PM , Performance Management , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , Problem

Product

SAP SuccessFactors Performance & Goals all versions