SAP Knowledge Base Article - Public

2658509 - Application Error Encountered while clicking on Investigate

Symptom

Error when accessing the 'Investigate' page in Workforce Analytics

"Error has occurred, please try again. See log for more information."

Environment

SAP SuccessFactors Workforce Analytics

Reproducing the Issue

  1. Login into the System
  2. Home > Workforce Analytics > Click on Investigate
  3. Application Error Encountered.

Cause

This issue will only happen if they land on one of the four APP Servers where error is encountered. A cookie is stored in the browser determining to which appserver they are allocated.

If you wish, you can check in which APP Server your request is hitting by replacing the "Login.aspx" for "lb.html" in the WFA URL found in Provisioning. I.e.:
https://analytics10.successfactors.com/Production/lb.html

Resolution

Firstly, raise a case to the SAP Support team to investigate.

Workaround: You may use a new browser or a private window as it will redirect the server call to one of four APP Servers. Which means you will have a 3/4 chance of accessing a working APP Server considering your original browser cookies will always redirect you to the currently faulty one. If the issue persists, try again in another browser until you are able to access a working APP Server while the Support team addresses the initial issue.

Keywords

Investigate, WFA, Workforce Analytics, error, logs. , KBA , LOD-SF-WFA-DES , Report Designer , Problem

Product

SAP SuccessFactors HCM Core all versions