Symptom
You are trying to navigate from the report CRMREGPRODHB_Q0001 to the registered product by clicking into the serial ID. In some cases however, you notice that this navigation does not work. You may get an error message like 'The target UI component is not assigned to any work center view. Please contact your administrator.'
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the work center Analysis, view Reports.
- Open the report CRMREGPRODHB_Q0001.
- Make sure the view contains the Serial ID.
- Click on the serial ID > Registered Product Details.
The registered product details do not open. Instead you get a window with the above message.
Cause
For this serial ID, there are several products so the navigation target is not unique.
Resolution
In order to navigate to the registered product, please make sure you always navigate from the report field Registered Product. This works irrespective of the number of products for the serial ID.
Keywords
report navigation, report to object navigation, registered product, serial ID, error, unique, serial number, ID double , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem