Symptom
The field Recurrences in Time Period in Routes is not calculated when adding an Account with Recurrence.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Visits work center.
- Go to the Routes view.
- Open a Route.
- In the Overview facet click on Add in Proposed Visits.
- Click on Show Advanced Filter.
- Select Add Recurrence and enter an Account with Recommended Frequency maintained.
- When you add the Account the field Recurrences in Time Period is not calculated.
Cause
To use the functionality Add Recurrence you have to add the field Visit Between maintained (start date and end date).
The field Recurrences in Time Period is calculated depending on the parameter maintained in Visit Between, when the dates range is higher there will be more recurrences.
The recurrences will be calculated in the Add Dialog on clicking Go to start the search for the relevant Accounts.
Resolution
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Go to the Visits work center.
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Go to the Routes view.
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Open a Route.
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In the Overview facet click on Add.
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Click on Show Advanced Filter.
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Click on Personalise and Start Personalisation or Adapt and Edit Master Layout.
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Hover the mouse over Accounts Advanced Filters fields until the icons are shown and click on Add Items > Add Field and select the field Visit Between.
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Click on Apply.
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Click on Personalise and End Personalisation or Adapt and End Layout Changes.
- Enter the required time frame in the fields Visit Between.
- Tick the box Add Recurrence.
- Click Go.
- Find the required Account and click Add.
Keywords
Recurrences In Time Period, Frequency, Visits, Routes , KBA , LOD-CRM-ACT-VST , Visit Planning , How To