Symptom
Service Technician Team Determination using Ticket Routing Rules with conditions set for Srv Location ZIP field is not working correctly.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Service and Social view.
- Click the Ticket Routing Rules hyperlink.
- Create new rule with condition for Srv Location ZIP field and value for Service Technician Team.
- Activate the rules.
- Go to the Service work centre.
- Go to the Tickets view.
- Click New.
- Add value for alpha-numeric postal code, like [X1...Xn] where X is any alphabet letter and n is any numerical value.
Result: for alpha-numeric postal codes, the Ticket Routing Rules do not work.
Cause
The Postal Code is based on alpha-numeric comparison, so you need to define the range based on alpha-numeric comparison rule.
Resolution
- Go to the Administrator work center.
- Go to the Service and Social view.
- Click the Ticket Routing Rules hyperlink.
- Create new rule with condition for Srv Location ZIP field and value for Service Technician Team.
- Maintain Srv Location ZIP field with the same length, for example [X001...X020]. Then X5 is X005 and it is in range. Else, you have to split and maintain conditions into many groups.
Keywords
Srv Location ZIP, alpha-numeric, Postal Code, Service Technician Team, Ticket Routing Rules, Post Code , KBA , ticket routing rules , alpha-numeric , srv location zip , postal code , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions