Symptom
Custom Fields created from the 'Custom Fields and Logic' app for the 'Marketing: Contact and Corporate Account' Business Context are not appearing in the new SAP Fiori Contact Profile.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Marketing Cloud Edition
Reproducing the Issue
- Create a Custom Field for the 'Marketing: Contact and Corporate Account' business context in the 'Custom Fields and Logic' app and enable the field for the Contact Profile usage.
- Open a contact using the new SAP Fiori Contact Profile and observe the newly created field is not there.
Cause
New Custom Fields do not appear automatically anymore. The fields need to be added using the Adapt UI function.
Resolution
The new Custom Field needs to be added using the Adapt UI function. Therefore open the contact in the SAP Fiori Contact Profile and click the User Icon in the Fiori Launchpad Header Area. This will enable the Adapt UI function and open the UI Adaption Mode.
Right click on the frame Additional Data and add the fields or create a new group first and then add the fields.
Save and Publish your work.
The field is available now.
Please make sure to assign the Role SAP_CORE_BC_EXT to the business user to enable the Adapt UI feature.
See Also
Please also refer to the online help and the 'Adapting the Contact Profile UI' Tutorial.
Keywords
Custom Fields and Logic, Marketing: Contact and Corporate Account, MKT_INTERACTION_CONTACT, Contact Profile, Adapt UI Benutzerdefinierte Felder und Logik, Kontaktprofi, UI Anpassen , KBA , CEC-MKT-DM-CON-FAC , Contact/Account Factsheet , Problem